How to ungroup a chart made with Datylon in Adobe Illustrator

Learn how to ungroup a Datylon chart to be able to apply Illustrator effects

If you are using Datylon for Illustrator, note that once a Datylon chart is expanded, the link with the data sheet is lost and cannot be recovered.

In case you want to re-use the chart, it is advised to first take a copy of the Datylon chart before expanding and manipulating it in Illustrator. 

 

To ungroup a Datylon chart, follow these steps: 

  1. Select the Datylon chart. Do not deselect the object until you're done. 

  2. In the Illustrator menu, go to Object > Expand... 

  3. Use the default values (Object and Fill enabled) and click OK.
    Your Datylon object is now a set of regular grouped Illustrator objects. In the Illustrator Layers panel, you'll see one or multiple <Group> layers, <Clip Group> layers and one <Clipping Path> Layer.
    ungroup
  4. Keep the object selected, go to Object > Ungroup and ungroup all those <Group> layers one by one. Easiest is to use the shortcut Shift+Cmd+G (Mac) or Shift+Ctrl+G (Windows) until all the <Group> layers disappear and you are only left with one or more <Clip Group> layers and the <Clipping path> layer.

  5. Keep everything selected and go to Object > Clipping Mask > Release. Repeat this as needed until all <Clip Group> layers disappear.

  6. Done! Now you can manipulate all the objects as you like. 

    ungroup2

Note there are invisible objects hidden in the chart, i.e. the original boundary box of the chart area and invisible axes if any. If you want to delete those objects, select one of those objects and go to the Illustrator menu Select > Same > Fill color. Then delete all selected objects.